1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

ECG-P2 and xLights Trouble

Discussion in 'RGB Lights - Intelligent Pixels and 3-Channel RGB' started by Maniaman, Dec 1, 2014.

  1. Maniaman

    Maniaman New Elf

    Joined:
    Feb 26, 2013
    Messages:
    8
    Likes Received:
    0
    Having trouble with my ECG-P2 and xLights.

    Running 4 strings in a row, injecting power at both ends and in the middle. 5V 2811.

    The pixels work as expected when running the ECG-P2 test pattern.

    When running with xLights, channels 1-1024 works fine (univ 1 & 2), 1025-1364 are off, and 1365-1536 light up but the colors are offset.

    Channels 1537 and above have a few random pixels lit but do not respond to xLights commands.

    In the ECG-P2 String Stats page I see I am getting Univ Overruns, but I haven't been able to get the configuration set between the P2 and xLights where I don't get the overruns.

    I'm stumped since they work fine with the test pattern but not with xLights.

    Any thoughts as to what could be wrong?
     

    Attached Files:

  2. Boof63

    Boof63 Senior Elf Generous Elf

    Joined:
    Nov 7, 2011
    Messages:
    549
    Likes Received:
    14
    Location:
    Kadina
    will l have a look at mysetup when I get home, but I think P2
    isn't correct
    How long are your strings?
    P2 Strings should be 1 , 150 for each string (If length is 5m of 30/metre)
    Also try speed down at 2400, I am 12volt but that works for me, so give it a try, even down to 1500.
    Cant be any more help at the moment sorry
    Cheers Boof
     
  3. nzlongfellow

    nzlongfellow Dennis from NZ

    Joined:
    Jan 2, 2014
    Messages:
    538
    Likes Received:
    0
    Location:
    Lepperton, Taranaki
    Find Me On:
    First thing is set xLights to 510 not 512. That will throw your numbers out as you cannot use 512 (170 x 3=510)
     
  4. OP
    OP
    Maniaman

    Maniaman New Elf

    Joined:
    Feb 26, 2013
    Messages:
    8
    Likes Received:
    0
    Kicked xLights channel counts down to 510 from 512. Still get universe overruns and colors on the second string are off with the 510 channel count in xLights. Still have the first chunk of string 3 out and all of string 4 out.
     
  5. OP
    OP
    Maniaman

    Maniaman New Elf

    Joined:
    Feb 26, 2013
    Messages:
    8
    Likes Received:
    0
    Solved! Had to set the Start Slot to 1 on all 4 strings/universes on the ECG-P2. Still getting a number of univ overruns, but I was able to chase 1 led from one end of the entire run to the other end and it worked great, and all of the lights are now responding correctly.
     

Share This Page