Falcon Player v1.6 is now available

Discussion in 'Sequencers & Software Tools' started by CaptainMurdoch, Oct 25, 2015.

  1. CaptainMurdoch

    CaptainMurdoch Apprentice Elf

    Joined:
    Jan 21, 2013
    Messages:
    52
    Likes Received:
    0
    The v1.6 release is via a UI upgrade button, there are no downloadable
    images for FPP v1.6. If you are already running v1.5, you need to
    first update to the latest v1.5 code by rebooting or using the
    "manual update" button. Once you are running the latest v1.5
    code, you should see a new 'upgrade' button appear below the menu
    which will allow you to upgrade your running v1.5 system to v1.6.


    Changes in v1.6 include:


    * Channel Output drivers
    - Zig Zag ability added to BBB String for F16-B/F4-B and other controllers
    - Virtual Matrix can now use RGB color order in addition to original BGR
    - New RPIWS281x Channel Output added to allow driving up to two strings of
    WS281x/TM180x pixels directly attached to the Raspberry Pi's GPIO headers
    - New Generic Serial Channel Output


    * General
    - Max channel count in a sequence bumped up to 512K
    - Remote status screen now shows sequence and media being played and position
    - New Channel Test UI and backend code, optimized for higher channel counts
    - New setting to enable routing between network interfaces
    - Audio playback is now supported on the BBB (still no video though)
     
  2. Jimbo

    Jimbo Full Time Elf

    Joined:
    Feb 27, 2014
    Messages:
    119
    Likes Received:
    0
    Is there instructions on how to install this new version onto the new Pi 2?
     
  3. darylc

    darylc Full Time Elf Global Moderator

    Joined:
    Dec 8, 2012
    Messages:
    328
    Likes Received:
    39
    Love the new test mode Captain!
     
  4. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,507
    Likes Received:
    1
    Location:
    Eaglehawk
    Find Me On:
  5. Jimbo

    Jimbo Full Time Elf

    Joined:
    Feb 27, 2014
    Messages:
    119
    Likes Received:
    0
    Thanks,

    What I mean is there instructions to install the 1.5 version on the new Pi2?

    Last I saw Aussie Phill had made a workaround, but I thought 1.5 was compatoble ith the new PI2 so wondering how to install this.
     
  6. darylc

    darylc Full Time Elf Global Moderator

    Joined:
    Dec 8, 2012
    Messages:
    328
    Likes Received:
    39
  7. OP
    OP
    CaptainMurdoch

    CaptainMurdoch Apprentice Elf

    Joined:
    Jan 21, 2013
    Messages:
    52
    Likes Received:
    0

    Thanks. I thought people would be much happier with it than the old hack that I threw in late last year. I have a lot more ideas for it, such as being able to test a single model or universe, but those will have to wait until next year.
     
  8. Jimbo

    Jimbo Full Time Elf

    Joined:
    Feb 27, 2014
    Messages:
    119
    Likes Received:
    0
    HI,

    Can I please get some clarification about the compatibility of the new version and installing on the new raspberry PI 2.

    I followed the instructions above to the letter on the PI 2 and it fails to boot into FPP.

    I then took the exact SD card out and put it into the Raspberry B+ I have and it boots up and works fine.

    On the Raspberry PI 2 - it tries to boot and then goes to a blank screen.
     
  9. logandc99

    logandc99 Dedicated Elf

    Joined:
    Jul 13, 2012
    Messages:
    1,075
    Likes Received:
    1
    Find Me On:
    I installed v1.6 on the pi2 last night. Can't say it was smooth sailing but that was initially due to a crappy SD card and the rest I presume due to operator error on my part. Had to install the software twice on the new SD card. Initially seemed to show all was good when it booted into Linux but later said file system needed repairing. Anyway, third attempt all seemed to go ok but took three reboots of the Pi to be able to access the web ui ( no idea why). Now working fine.
     
  10. Gilrock

    Gilrock Full Time Elf

    Joined:
    Jan 4, 2013
    Messages:
    380
    Likes Received:
    4
    Location:
    Tucson, AZ
    Find Me On:
    Jimbo v1.5 was compatible with Pi2 so v1.6 is also. There can be many things that cause problems. I had trouble getting v1.5 to work on my Pi2 and even though I thought I had bought a really nice class 10 SD card I went out and bought another one that was half the storage size and it worked fine.
     
  11. Jimbo

    Jimbo Full Time Elf

    Joined:
    Feb 27, 2014
    Messages:
    119
    Likes Received:
    0
    I am onto my 3rd sd card an still can't get it to work properly.

    These cards work fine in the B+.

    Will try again. Any known issues with the Scan disk micro cards?
     
  12. Gilrock

    Gilrock Full Time Elf

    Joined:
    Jan 4, 2013
    Messages:
    380
    Likes Received:
    4
    Location:
    Tucson, AZ
    Find Me On:
    There is also the chance your Pi2 is the problem. I saw one at the Expo this summer that the captain told the user it was dead out of the box.
     
  13. smartalec

    smartalec Im a SmartAlec what can i say! Community Project Designer

    Joined:
    May 4, 2010
    Messages:
    1,183
    Likes Received:
    7
    Location:
    S.A.
    Find Me On:
    whats the error people are getting with rasp pi fpp install (best to have a monitor attached to know whats going on)
    as i had a issue.. but i reckon that could of been me..
    as i ended up getting it going, but had to use my linux computer to kick the process off.

    my issue is when it first booted up, it said there was a incorrect format, an could'nt use the partition manager to make the partitions for the install to work..

    i would be interested if others are having this issue or a new issue then i can report it back to the captain it fix)
     
  14. Gilrock

    Gilrock Full Time Elf

    Joined:
    Jan 4, 2013
    Messages:
    380
    Likes Received:
    4
    Location:
    Tucson, AZ
    Find Me On:
    With my Pi2 I know I started with a 32GB SD card and it was failing and I changed to a 16GB card and it worked first try. I had the HDMI hooked up and remember it was getting stuck on one of the earlier steps. I think my results are in a post on the FPP site.
     
  15. Gilrock

    Gilrock Full Time Elf

    Joined:
    Jan 4, 2013
    Messages:
    380
    Likes Received:
    4
    Location:
    Tucson, AZ
    Find Me On:
    I found my post on FPP forum. The 32GB card was getting hung at the start saying "Clearing Existing EBR". It gets to 32% and then never progresses. When I switched to the 16GB card it was getting past that step in a couple seconds. I'm also now using that same 32GB micro SD card in my GPS with no issues.
     

Share This Page