1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

Mega 60 stalling

Discussion in 'Hanson Electronics' started by AlexB, Dec 1, 2015.

  1. AlexB

    AlexB New Elf

    Joined:
    Nov 2, 2012
    Messages:
    45
    Likes Received:
    0
    Location:
    South of Brisbane
    Hi All \ Alan,


    I'm running a Mega60 out of the DMX output of a P12. I've had it running in testing for over a month now, but never ran for more than about an hour or so.


    I did a final test on Sunday night, and my show commenced last night, and i've noticed that at some point after about 2 hours (the show runs for 3) all the lights attached to the M60 go full 100% white and stay that way until the board is power cycled. This happened on both nights - Sunday I noticed it about 5 minutes after it happened, cycled and all returned to normal - but last night I didn't notice until the show finished at 10pm, and these elements were all still on.


    The board was purchased somewhere between March and June this year, so I assume it's running latest firmware (says v1.9 on the board)


    I'm running LSP 2.8 Advanced, all multicast (all told there is about 600 channels).
    I'm only using zone 1 and 2 of the board - zone 3 and 4 are empty, and therefore not powered.


    If anyone's come across this and has any solutions, i'm well open to them, otherwise i'll await Alan's advice.


    I really hope it's not a faulty board!
     
  2. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,537
    Likes Received:
    14
    Location:
    Eaglehawk
    Find Me On:
    Latest firmware is 2.1 and that allows the board to reset the latched up led driver which prevents anything from happening. I hope to have a new firmware out very soon that will make the reset more seamless as currently there is the potential for a flicker on the outputs while the start address is read from the dipswitches.
    A pickit2 or pickit3 is required for the firmware update. Firmware 2.1 was announced on http://auschristmaslighting.com/forums/index.php/topic,7872.0.html back at the end of September.
     
  3. OP
    OP
    AlexB

    AlexB New Elf

    Joined:
    Nov 2, 2012
    Messages:
    45
    Likes Received:
    0
    Location:
    South of Brisbane
    Damn. I'd thought the latch issue was fixed in 1.7? (here: http://auschristmaslighting.com/forums/index.php/topic,5424.0.html) so it was still present in 1.9?


    Could also be the DMX issue I guess - both times i've come in to reset it the green LED was off.


    Anyone nearby have one of these doodads locally? I don't have any option to buy one at present.
     
  4. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,537
    Likes Received:
    14
    Location:
    Eaglehawk
    Find Me On:
    That latching up has been the bane of my life for 2 years now. On the bench I have never been able to replicate the issue but I finally worked out a successful fix for it. Resetting the micro didn't work as it was a latched up bus on the led driver chip. I will send 1 of my PicKit 3's through to you in the post tomorrow.
     

Share This Page