DCG/uDCG-P2 Firmware for WS2811 Pixels?

adski

Dave Brown
Joined
Feb 15, 2012
Messages
203
Location
Two Wells, SA
Hey Ed - just wondering when we'll see WS2811 support for the DCG series controllers - I'm stumped without it! My aging brain assumed that it would be straightforward to port the pixel driver code from the ECG controllers, but there's, no doubt, more to it than that.

Dave
 

bbayjohn

Senior elf
Joined
Mar 4, 2012
Messages
574
Location
Batemans Bay
Hi adski, did you ever get the udcg-p2 working?Did you find an update?
I would really like to get this working this year. I Need to find some help files if anyone can point me in the right direction. Like how do I map the channels to this unit. With the help of Yag and LL last year we were able to get the test run to work. Now I have a p12s that has dmx output, I should get it to work.
Cheers
John
 

adski

Dave Brown
Joined
Feb 15, 2012
Messages
203
Location
Two Wells, SA
Hi John

No, I never managed to get it working properly (using the TM1804 substitute for the 2811) and as you can see, there was no response from Ed.

I haven't seen any updates on the forums and there's nothing on the j1sys web site - the DCGs don't rate a mention anywhere.

I bought a few E6804s to get me going this year, but like you, I'd like to get the DCGs working as well.

Cheers
Dave
 

neilric99

Full Time elf
Joined
May 20, 2010
Messages
295
Location
Irvine, the OC, CA
I am waiting on the uDCG-P2 update as well to drive my ws2811's and strobes as well as some other standalone elements.

Ed is saying that it is a #1 priority so I am hoping (praying) soon.
 

bbayjohn

Senior elf
Joined
Mar 4, 2012
Messages
574
Location
Batemans Bay
Well I managed to to get my ws2811 string to work. Be sure to read the
uDCG-P2 – Quick Notes to configure the jumpers first before powering.
Boot loader below
http://auschristmaslighting.com/forums/index.php?action=dlattach;topic=2450.0;attach=2407
http://www.j1sys.com/legacy/UBL_Quick.swf
With the below string set up commands be sure to type it the SAME format as below. Ie capitals and spacing. You will need to change it to set your channel configuration but this is what works for me.
string num=1 act=1 type=TM180X speed=3000 univ=1 start=226 pixels=20
string num=2 act=1 type= TM180X speed=3000 univ=1 start=287 pixels=50
save
reboot

Now the test

network host=’Test 1’ test=1 speed=250
save
reboot
TO TURN OFF (not that this part works for me have to power down to turn off, maybe the update will help with this)
network test=0
save
reboot
Still yet to test controlling the board but that will be another night as its getting late. I plan on running the udcg-p2 from a p12s dmx output.
Hope this helps
John
 

bbayjohn

Senior elf
Joined
Mar 4, 2012
Messages
574
Location
Batemans Bay
neil said:
I am waiting on the uDCG-P2 update as well to drive my ws2811's and strobes as well as some other standalone elements.

Ed is saying that it is a #1 priority so I am hoping (praying) soon.
I second that. Soon has been a long wait. Please Ed, I would like to run them this year .
 
Top