FPP Connect

vk3heg

Full time elf
Joined
Dec 10, 2018
Messages
147
Location
Ballarat
Hi Guys,

Xlights: 2023.18
FPP: 4.6

I have FPP 4.6 installed on my two Pi's, and went to "upload/connect" via the tools/fpp connect tool option. Xlight's didn't list or detect either.
I have full access to the pi's via web/ssh etc, so they are on the same network.

Has there been a recent change to the version support in xlights?

As a quick test I used another pi and installed 6.3 on it, and xlights detected the fpp setup.

One of my pi's is in a very hard to get to location, and will require puling the proop apart along with support hardware, and as such Id rather not have to.


Cheers,
Stephen
 

thewanderingpine

Full time elf
Generous elf
Joined
Mar 13, 2021
Messages
336
There was a change (in one of the early 2023 xLights builds). You will need a newer FPP.
 

thewanderingpine

Full time elf
Generous elf
Joined
Mar 13, 2021
Messages
336
(There are now options to patch FPP in place online - but I’m not sure they support 4.6)
 

thewanderingpine

Full time elf
Generous elf
Joined
Mar 13, 2021
Messages
336
Need to download the FPP 5.5? Image, upload it to your pi, install that.
then connect to that, upgrade again to 7.x.
Then it should work.
 

vk3heg

Full time elf
Joined
Dec 10, 2018
Messages
147
Location
Ballarat
Thanks for the info. I've downloaded xlights 2023.1 and will test that tomorrow. I'm in the final stages of setup and don't want to have to re-doo the fpp installs.
 

Skymaster

Crazy elf
Global moderator
Generous elf
Joined
Dec 19, 2021
Messages
1,155
Location
Western Sydney
xLights 2023.3 was the first to warn that FPP < 6 would be no longer supported. FPP 2023.11 was the last to support FPP < 6. Any thing after that just fails.
 

Indigogyre

Journeyman Elf
Generous elf
Joined
Jun 26, 2021
Messages
445
I'd suggest installing an older version as Skymaster suggested and ONLY use it for FPP connect to upload files for you. You can install it to a different directory and have both versions installed at the same time. This will give you more time next year to properly install everything. I made the mistake of putting a PI in a prop and need to open it next year to fix that issue.
 

vk3heg

Full time elf
Joined
Dec 10, 2018
Messages
147
Location
Ballarat
I tried 2023.6 but got upload 404 errors saying it couldn't find files after the upload.
Removed all xlight versions, and installed 2023.1. I've got that working with no issues related to xlight's.
 
Top