1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

LSP Frustrations

Discussion in 'LightShow Pro (LSP)' started by ԆцряєсϮ, Nov 21, 2013.

  1. ԆцряєсϮ

    ԆцряєсϮ Senior Elf

    Joined:
    Dec 24, 2011
    Messages:
    502
    Likes Received:
    1
    Location:
    Botanic Ridge
    Find Me On:
    I thought I'd add my frustations to the LSP debate.
    It seems to be getting worse with 2.8 :-\
    For all the new things that you can do there seems to be 3 things that it wont do properly.
    Heres what I've been getting all loud and throwing stuff about for for the last 2 weeks while I've been trying to put some sort of show together.


    Macros
    1) - Only seem to work some times.
    eg.
    1) Created a Plasma macro of about 4 secs on my Roof Layer, used the slime colour preset. All good
    Created another Plasma macro on the Windows layer (Same Timings) using the rainbow colour and LSP went and created various coloured ramp down effects right through to the end of the sequence (outside the macro and only on some of the channels)


    2) Again created a macro on a layer same as above (all good) then tried to create a similar macro on another layer but using the colour pallette instead of the presets and it only draws Black effects?? I cant get a plasma macro to work with any other colour than the presets.


    Same with transitions, some work some just generate black effects?


    Timings


    Using touch mode to create timing marks, if I put one in the wrong spot when I try to move it it moves the 4th one to the left or 3rd one to the right??? This seems to happen every 3rd or 4th time.
    If I try to delete them using right click sometimes they delete, other times they don't so I have to move them instead??


    Cut and Paste


    Ive givin up on cut and paste for Version 2.8, no matter what I try it always either pastes something entirely different to what I copy or it pastes it 4 cells to the right/left (take your pick)


    Controllers
    3 times this has happened
    I click on one of my small 1 channel controllers and it dissappears, for some reason it merges with another controller. Ok so I must have dragged it in there, fair enough but how do you get it out with out deleting it??


    Thankfully I save very often so I just close and restart to try and reset everything.




    I dont remember last year being this hard. :-\
    Would love for someone to say "your doing this wrong or that wrong"
    would certainly speed up my sequencing thats for sure.


    Rant over!
     
  2. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,617
    Likes Received:
    36
    Location:
    Eaglehawk
    Find Me On:
    I'm afraid it has to be said as you wanted someone to say it. You're doing it wrong. Use LOR ;)

     
  3. Beacy

    Beacy It's so much better on the dark side

    Joined:
    Jun 10, 2010
    Messages:
    466
    Likes Received:
    0
    Location:
    Beaconsfield
    Rod


    Touch mode - they might as well remove the buttom for all the use it is.


    Agree with cut & paste it sucks and should have been picked up and fixed long ago, but I have learnt how to account for the fault when I paste.


    Dragging controllers pain in the ass You need to select with your mouse 2 or 3 controllers above the one you want to move.


    I don't use the macro's if they cant get the simple thigs right then I dont trust the bigger things.

    IMO given the hype about how great it was going to be it is just another year of disappointment deleivered by LSP I am amazed that it has taken 10 months to deliver essentially what I had last year.


    The other options are no better LOR locks you to their products and is a dog to use and Vixen would do my head in with the number of channels I have.


    So I guess we just battle on with LSP and wait for the next round of undelivered promises.
    PS You will note by my tone I am fighting LSP as I write this post. But haven't resorted to CAPS LOCK YeT
     
  4. Kaden

    Kaden Pixels! I need more pixels!

    Joined:
    Jan 10, 2012
    Messages:
    724
    Likes Received:
    0
    Location:
    Gold Coast

    My show last year with LOR was entirely supplied by Ray Wu and J1sys (pixels and e1.31), the only thing I purchased from LOR was the software itself.
     
  5. talk2coxie

    talk2coxie Full Time Elf

    Joined:
    Dec 29, 2010
    Messages:
    141
    Likes Received:
    0
    Location:
    Heathcote NSW
    Find Me On:
    I have found a fix when trying to drag and move controllers and would be interested to hear if it helps you guys too.
    I had similar issues when trying to drag a controller up or down it wouldn't grab the controller I wanted or it has merged with another controller before as well.

    What I did do which seems to fix these issues is make sure all controllers are not expanded. I can easily move controllers as one would expect as long as all of the controllers are collapsed.

    It isn't ideal but works for me, hope this is of some help?
     
  6. burner

    burner Full Time Elf

    Joined:
    Nov 2, 2011
    Messages:
    315
    Likes Received:
    0
    I've also found that when moving controllers, take it slowly and wait for it to "catch up" with you before letting go of the button.
    With the copy/paste, I've gotten better at expecting what LSP is going to do. I also find zooming in more helps to paste where I want things. If you are getting stuck with copy/paste, another option is to copy to a pattern first and then drag in from that (sometimes this has helped me).

    With the timing marks, that random problem plagued me too. I had to drag, CTRL Z (to undo), and repeat sometimes 4-5 times before it would drag the timing mark I was on and trying to move. Sometimes selecting a different timing mark and going back helped.

    I'm glad I finished sequencing now, and will be doing a recording tomorrow night for review (hopefully through the scheduler). I had some issues with my wiring (cheated by using some 7/20 wiring for 8 lengths instead of buying some more cable. BIG MISTAKE!!!. Once I replaced all that wiring last night, my flickering effects all went. One thing (gripe) I noticed as I was packing up (although the demo mode worked), I accidently clicked on configure controllers in LSP on channel 11 and then cancelled out. When I did the song test, channel 11 didn't work at all. didn't cross my mind that it was an issue with LSP, so I troubleshooted my cabling this afternoon. When everything looked o.k. and the demo mode worked, I had another look at LSP, and sure enough, channel 11 said it was configured, but when I went into it, there was no information there.
     

Share This Page