1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

LSP Unstable

Discussion in 'LightShow Pro (LSP)' started by Jimbo, Sep 8, 2014.

  1. Jimbo

    Jimbo Full Time Elf

    Joined:
    Feb 27, 2014
    Messages:
    119
    Likes Received:
    0
    Hi,

    I am writing to vent my frustration with LSP and a continual problem I am having.

    Every 2 weeks or so it comes up with when clicking to open "Aproblem caused the program to stop working correctlyy. PLease close the program).

    I have then had no choice but to re-install LSP again (sometimes taking several rounds of installation before it will work again).

    I am now going through this process for the 8th time. I also loose my latest version of my work and have to revert to the last backup.

    Why is LSP doing this?

    What is the Problem ausing to program to stop working?
     
  2. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,537
    Likes Received:
    14
    Location:
    Eaglehawk
    Find Me On:
    What build of lsp are you using, the version of windows and the pc specs?

    I'm afraid I actually had a chuckle at your expense Jimbo. I feel for you as you never want to lose work and you really should never need to do program and especially an OS reinstall. In chat I'm often critical of the incredible instability of LSP. The fanboys say that they never have a problem with it and ever since version (insert 40 digit number here) it has been rock solid.
     
  3. OP
    OP
    Jimbo

    Jimbo Full Time Elf

    Joined:
    Feb 27, 2014
    Messages:
    119
    Likes Received:
    0
    I do like LSP but having these issues is annoying.

    I have the latest LSP version. I downloaded it in July as i bought the license and needed the new version for my license to work.

    I am using windows 7. Its a i7 3.5khz quad core, 8 gig ram, gigabyte motherboard.

    Its like every 2 weeks it does this. Like the issue i had with the display preview is based on the setting of the resolution. I have had to try many things to find a solutions to the problems. I only post so as I find solutions it might help other people out.
     
  4. dale82

    dale82 Senior Elf

    Joined:
    Nov 19, 2010
    Messages:
    567
    Likes Received:
    0
    Location:
    Kingaroy
    I have used LSP now for over 12months and I haven't had to do this at all, While its creating effects are you clicking around? Im just trying to understand what your doing at the point of it telling you that you have to close it.
     
  5. arw01

    arw01 Full Time Elf

    Joined:
    Dec 30, 2013
    Messages:
    384
    Likes Received:
    1
    Location:
    Eastern Washington
    Also never have this issue, there is another issue at the root cause.


    You on 64 bit or 32 bit? 64 bit has less issues.


    What is your channel count?


    Having to go back to backup sounds like file corruption, having to reinstall sounds like file corruption. What's the state of your hard drives, e.g.have you run a full diagnostic with read every single sector to make sure you don't have a failure creeping in?


    I've had LSP sequencer running a week at a time through sleep, hiberation, etc.. I can "crash" it with some map to matrix functions but I don't loose my work.


    Do you have the automatic backup on? what level of undo do you have set?
     
  6. OP
    OP
    Jimbo

    Jimbo Full Time Elf

    Joined:
    Feb 27, 2014
    Messages:
    119
    Likes Received:
    0
    It does this when I turn on the computer and then try to open LSP.

    It doesn't occur whilst I am programming.

    I only have 2,000 channels.

    It is 64 bit. Brand new hard drives. Reguarly maintained.

    Everytime it has done this, it has been after the initial bootup.

    Undo level is at 20
     
  7. fasteddy

    fasteddy I have C.L.A.P Global Moderator Generous Elf

    Joined:
    Apr 26, 2010
    Messages:
    6,487
    Likes Received:
    19
    Location:
    Albion Park NSW
    Find Me On:
    When you say 'regularly maintained' do you use optimizer programs and such to maintain your hard drives. Programs like this are well known to cause issues with moving files that they shouldn't and causing installed programs to crash.
    If its happening every 2 weeks it seems like it may coincide with something your computer may be doing, so I would look at what you have that may be scheduled every 2 weeks that may effect LSP installation.

    And as for AAH calling us fan boys, its to be said that LOR has its fan boys that are happy to suggest using 10 different addon 3rd party programs to get the same functionality as LSP and then do memory workaround so it works with larger channels :eek: , There is no perfect software and in fact all software has its own fan boy base. :)
     
  8. AussieDoug

    AussieDoug Full Time Elf

    Joined:
    Dec 1, 2012
    Messages:
    375
    Likes Received:
    0
    Just wondering what size graphics card do you have?
     
  9. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,537
    Likes Received:
    14
    Location:
    Eaglehawk
    Find Me On:
    I only said fanboy as there are some people who seem to have forgotten that they have had crashes galore. The functionality and all the good things that lsp does seems to make people forget the crashes and the frustration that they've had. I use LOR not because of it's ease of use and stability. I know it lacks features but I personally haven't had an issue with that. It's a pretty well known fact that I wear my heart on my sleeve and it absolutely does my head in when things or people don't do as they say they can do.
    Anyway back to Jimbo's problem. LSP creates (or at least used to) a log file of every session. It's entirely possible that the reason for the crashes may be embedded in the file. It may be worthwhile forwarding the file to the lsp gurus or at least the section that corresponds to the last session before it crashes up to when it crashes.
     
  10. arw01

    arw01 Full Time Elf

    Joined:
    Dec 30, 2013
    Messages:
    384
    Likes Received:
    1
    Location:
    Eastern Washington
    I think Eddy could be onto something, every 2 weeks sounds like a defrag routine running.


    The logs might give some hints and may go back a ways, or may go away with the re-installs.


    For kicks I would look for a md5 checksum program and run them on the DLL's for LSP, if they are change then you know you have culprit, if they don't change, then you know the OS is the culprit in some manner.
     
  11. OP
    OP
    Jimbo

    Jimbo Full Time Elf

    Joined:
    Feb 27, 2014
    Messages:
    119
    Likes Received:
    0
    Let me correct,

    Since I reinstalled windows, and the whole system about 2 weeks ago now I have not run any de frag or any other program prior to this happening.

    Before when I said every 2 weeks - it can be 2-3 weeks when this occurs. Its not exactly at the same time.

    I am thinking it may have something to do with my computer being newer then most on here that use LSP. Ie no one else seemed to have had the trouble i had with the display preview running poorly (turned out to be that in the higher resolution of the 2nd monitor I had for the display preview made it play funny and muck up, and when I set it back to 680 it works fine).

    I have the new intel i7 chip 4790K and not sure if this maybe the issue or not.

    I am not going to get into the whole LSP vs LOR debate lol. I really do like LSP, but for some reason I seem to be having these issues no one else has. I am trying to find the common denominator in all of this.

    Over time I have found the causes/solutions and thankfully LSP does have a very good backup position in regards to the backup files it creates.

    I'll look up and see if any defrag or something is occurring that might be contributing to this.

    Thanks everyone for your responses.
     
  12. dale82

    dale82 Senior Elf

    Joined:
    Nov 19, 2010
    Messages:
    567
    Likes Received:
    0
    Location:
    Kingaroy
    "I have the new intel i7 chip 4790K and not sure if this maybe the issue or not. "

    I am also running this chip and don't have the issue that your having mate. Hopefully you find out what your issue is soon.
     
  13. fasteddy

    fasteddy I have C.L.A.P Global Moderator Generous Elf

    Joined:
    Apr 26, 2010
    Messages:
    6,487
    Likes Received:
    19
    Location:
    Albion Park NSW
    Find Me On:
    Do you have auto save on, if so turn it off.

    What was the last thing you did in LSP before it broke, do you ever do a forced shut of LSP or the computer when LSP is running before this issue happens

    Try a fresh download of LSP and then do a complete uninstall and also delete the folder and then reinstall fresh if you haven't already done this to eliminate any file or installation issues. If the issue then persists then we need to start looking at other possible causes and eliminated those.
     
  14. arw01

    arw01 Full Time Elf

    Joined:
    Dec 30, 2013
    Messages:
    384
    Likes Received:
    1
    Location:
    Eastern Washington
    You are looking for minleon folders in the program files and app data directories btw way..
     

Share This Page