Matrix outline submodelling

crazymofo

New elf
Joined
Jan 7, 2021
Messages
38
I am playing around with an updated layout for this year and am currently fiddling with a few matrixes. I have submodelled an outline on them. If i put an effect on the matrix model itself, and an effect on the outline submodel it works as i expect ie. the outline renders over the top of the matrix effect. But if i put the outline submodels in a group and place an effect via this group, the matrix effect renders over the top of it. I have tried placing the group above and below in my render order but still the same issue. Any simple thing that i may be missing? Thanks
 

merryoncherry

Full time elf
Generous elf
Joined
Apr 2, 2022
Messages
361
Location
Cherry St., Hudson MA USA
It works. The question is where you may have missed a step... could be as simple as display elements, render all, or something. Let's walk through a working config and maybe you'll spot a place where you got off track.

First, the layout. I've created a matrix, with 2 submodels; one submodel is a single strand border, the other is a multi-strand inside. That second one isn't used in these examples, but you might consider it... then the effect stays inside the area not used by the outline, which may or may not be what you want. I've added each of these things to a group. In my case I named the groups in alphabetical order so that they match the render order I want.
MatrixSetup.png

Then I create a sequence. It's worth checking that the display elements are sorted the way you want. Ones lower in the list will overwrite the early ones.
You can also see the effects I've chosen - a blue butterfly on all matrix, and a red+green chase for all outlines.
DisplayElements.png

The effect is what I want / what I thought you want:
Effect.png

Now, if I did put the butterfly on "Matrix", it won't do this any more, because "Matrix" is last in the list. Then it will be all blueish.
NotRight.png

The solution may be to change the order in Display Elements - or do something else (use the inside submodel, add another group, etc.) if you sometimes want one thing and sometimes the other.
ChangeOrder.png

But wait! It didn't work?! Don't forget to "render all" before you panic. Just click here... Whew!
ClickHere.png
 

crazymofo

New elf
Joined
Jan 7, 2021
Messages
38
Playing around with it this afternoon after reading your reply, and have done some testing. Included some screenshots.

Here is my outline submodel group, labelled "test" (outlines of both matrix either side of tree/stars).
outline_group.JPG

Here is a group that i included only the right-side matrix, labelled "test2".
matrix_group.JPG

Here is my render order:
render_order.JPG

As you can see, I have imported effects onto the LEFT matrix on its own, the same imported effects onto the "test2" group which has the RIGHT matrix in, and a house outline effect on the "test" group which holds outline submodels for both matrix.

Here is a screenshot of what i get. Left side is what I am chasing, right side is how it comes out by the matrix being in a group:
result_fail.JPG

This was the conclusion i came to last night as well.
 

crazymofo

New elf
Joined
Jan 7, 2021
Messages
38
That did it!! Thank you so much. Always that one step that will make the difference
 
Last edited:
Top