Musical sequences not playing in FPP

daunce

Apprentice elf
Joined
Jun 9, 2010
Messages
79
Location
Ferntree Gully, VIC
I have FPP (with P10 panels), and a Falcon f16v3 with the rest of my models.

Using FPP in standalone mode, some sequences work (animation), while others (musical) don't. FPP outputs to all lights when in Display Testing, and each individual model works when selected, so I know the wiring and universes/channel numbers are correct.

In the Display Testing page, the musical sequence works, but it doesn't play from the Status Page. When I press play on the musical sequence, the elapsed time and remaining time don't change.

I did have other animated sequences that didn't work, but after some fiddling I was able to get it to work.

I can't work out why some work, but not the others. If they're created from the same xLights config, and uploaded using FPP Connect, what would cause one to work, while others don't?

Are there any gotchas when using musical sequences in FPP? In FPP Connect, I've tried FSEQ v2 and v2 sparse.

FPP is running 3.4.2.

[Edit. Just changed a musical sequence to animation, and sent it to FPP. It works fine in FPP without the mp3. The Audio plays ok in xLights.]
 
Last edited:

Dave_Szoka

Full Time elf
Generous elf
Joined
Jan 1, 2014
Messages
132
Location
Hobart
I think once P10s are attached to your PI it disables the audio output-- You will need to use a USB Audio Card to get audio out-- No Audio out-- No Play
 

daunce

Apprentice elf
Joined
Jun 9, 2010
Messages
79
Location
Ferntree Gully, VIC
ah. Thanks. Looking for information around that helped.

From the FPP Content Manager, I'm able to play the audio file through the browser, but not through FPP to the 3.5mm plug.

Checking the logs: fppd.logs:
Code:
2019-11-05 14:46:39.133 (1319) mediaoutput/SDLOut.cpp:641:Could not open audio device - ALSA: Couldn't open audio device: No such file or directory
2019-11-05 14:46:39.518 (1319) playlist/PlaylistEntryMedia.cpp:160:Could not start media Mariah Carey - All I Want For Christmas Is You.mp3
From Alan's rPi-10 page:
You need to reboot to disable the onboard audio which conflicts with the third output connector.
I know I have a USB sound card somewhere from when my show computer was a VM, but I can't find it. If I want to find it soon, I'll have to buy another one first. That's how these things go.
 
Top