Nutcracker: bug fix, lms and lcb files now fixed

smeighan

Dedicated elf
Joined
Jan 19, 2012
Messages
1,109
Location
4217 Greenfinch Dr CO 80126

Superman

I Have C.L.A.P and its very infectious
Global moderator
Joined
May 29, 2010
Messages
1,716
Location
Ipswich-QLD
Hi Sean.

I had a big play with this tonight .
very,very close.
when opening a LMS file for my tree created by Nutcracker it doesn't import the last 3 channels.
I did manage a way to get around that by just added 3 channels to the end of the last controller, just means that little light won't be blinking.

also when it import into LSP as a LMS as you explained it comes in as single channel numbers.
ch 1 RED
ch 2 Green
ch 3 Blue

I tried to change them to RGB channel groupings but LSP it is still having trouble working out the LOR RGB ch format and all the effect combine and just show up as white.
This is not a big deal in LSP the tree just needs to be drawn a bit differently.

I have sent you a video screen shot of my troubles.

Well done. it's starting to come together nicely.
 

smeighan

Dedicated elf
Joined
Jan 19, 2012
Messages
1,109
Location
4217 Greenfinch Dr CO 80126

smeighan

Dedicated elf
Joined
Jan 19, 2012
Messages
1,109
Location
4217 Greenfinch Dr CO 80126
ѕυρєямαη said:
Hi Sean.

I had a big play with this tonight .
very,very close.
when opening a LMS file for my tree created by Nutcracker it doesn't import the last 3 channels.
I did manage a way to get around that by just added 3 channels to the end of the last controller, just means that little light won't be blinking.

also when it import into LSP as a LMS as you explained it comes in as single channel numbers.
ch 1 RED
ch 2 Green
ch 3 Blue

I tried to change them to RGB channel groupings but LSP it is still having trouble working out the LOR RGB ch format and all the effect combine and just show up as white.
This is not a big deal in LSP the tree just needs to be drawn a bit differently.

I have sent you a video screen shot of my troubles.

Well done. it's starting to come together nicely.

Thankyou for the video (145mb). It shows me some stuff i had not seen. Since i have never used LSP, i didnt know how to create trees.


As far as the last pixel of the last string. I saw that bug last night but decided to release the code since it was totally broken before. I will be fixing the 1 pixel missing bug. In your 2400 channel tree (800 pixels), my file gives you only 2397 channels. I am glad there was a work around, This buys me some time to fix the bug.


As far as text, i am missing the bottom row of the second line of text. Other than that, it now looks like text loads correctly.
 
Top