1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

Nutcracker: bug fix, lms and lcb files now fixed

Discussion in 'xLights (Nutcracker)' started by smeighan, Apr 24, 2012.

  1. smeighan

    smeighan Dedicated Elf

    Joined:
    Jan 19, 2012
    Messages:
    1,066
    Likes Received:
    9
    Location:
    4217 Greenfinch Dr CO 80126
  2. DeeJai

    DeeJai Is that Magic Smoke?!?

    Joined:
    Oct 18, 2011
    Messages:
    1,007
    Likes Received:
    0
    Location:
    No longer in Radelaide
    is it just me, or can you not view the vids either?


    *Edit* Never mind, just me.... All working
     
  3. DougieB

    DougieB Full Time Elf

    Joined:
    Aug 3, 2011
    Messages:
    277
    Likes Received:
    0
    Location:
    Gladstone, Qld
    both links open up the LSP video
     
  4. Superman

    Superman I Have C.L.A.P and its very infectious Global Moderator

    Joined:
    May 29, 2010
    Messages:
    1,627
    Likes Received:
    15
    Location:
    Ipswich-QLD
    Find Me On:
    Hi Sean.

    I had a big play with this tonight .
    very,very close.
    when opening a LMS file for my tree created by Nutcracker it doesn't import the last 3 channels.
    I did manage a way to get around that by just added 3 channels to the end of the last controller, just means that little light won't be blinking.

    also when it import into LSP as a LMS as you explained it comes in as single channel numbers.
    ch 1 RED
    ch 2 Green
    ch 3 Blue

    I tried to change them to RGB channel groupings but LSP it is still having trouble working out the LOR RGB ch format and all the effect combine and just show up as white.
    This is not a big deal in LSP the tree just needs to be drawn a bit differently.

    I have sent you a video screen shot of my troubles.

    Well done. it's starting to come together nicely.
     
  5. OP
    OP
    smeighan

    smeighan Dedicated Elf

    Joined:
    Jan 19, 2012
    Messages:
    1,066
    Likes Received:
    9
    Location:
    4217 Greenfinch Dr CO 80126

    Not you. I posted a broken link. Then tried it in each forum, saw the error and went back and fixed it.
     
  6. OP
    OP
    smeighan

    smeighan Dedicated Elf

    Joined:
    Jan 19, 2012
    Messages:
    1,066
    Likes Received:
    9
    Location:
    4217 Greenfinch Dr CO 80126

    I have fixed the first link, now you het both videos
     
  7. Benschristmaslights

    Benschristmaslights Dedicated Elf Global Moderator Generous Elf

    Joined:
    May 2, 2010
    Messages:
    2,125
    Likes Received:
    7
    Location:
    Elderslie
    Find Me On:
    first link still not opening second one works fine
     
  8. OP
    OP
    smeighan

    smeighan Dedicated Elf

    Joined:
    Jan 19, 2012
    Messages:
    1,066
    Likes Received:
    9
    Location:
    4217 Greenfinch Dr CO 80126
  9. OP
    OP
    smeighan

    smeighan Dedicated Elf

    Joined:
    Jan 19, 2012
    Messages:
    1,066
    Likes Received:
    9
    Location:
    4217 Greenfinch Dr CO 80126

    Thankyou for the video (145mb). It shows me some stuff i had not seen. Since i have never used LSP, i didnt know how to create trees.


    As far as the last pixel of the last string. I saw that bug last night but decided to release the code since it was totally broken before. I will be fixing the 1 pixel missing bug. In your 2400 channel tree (800 pixels), my file gives you only 2397 channels. I am glad there was a work around, This buys me some time to fix the bug.


    As far as text, i am missing the bottom row of the second line of text. Other than that, it now looks like text loads correctly.
     
  10. Superman

    Superman I Have C.L.A.P and its very infectious Global Moderator

    Joined:
    May 29, 2010
    Messages:
    1,627
    Likes Received:
    15
    Location:
    Ipswich-QLD
    Find Me On:
    Too big Sorry about that. at least it was high-def.lol

    I've u-tubed the sequel
     

Share This Page