1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

Pixel strips and the p12r and LSP

Discussion in 'RGB Lights - Intelligent Pixels and 3-Channel RGB' started by z_special, Dec 5, 2012.

  1. z_special

    z_special Full Time Elf

    Joined:
    Feb 2, 2012
    Messages:
    111
    Likes Received:
    0
    Location:
    Edmonton Alberta
    Ok here goes. I have a 30 pixel strip of flex pixels hooked to a p12r with 4 metrs of 2 pair sheilded belden cable between. Now when I test the hardware thru LSP and tell it to turn on the first pixel it does that, but will not turn it off. if I turn the whole bank on they come on but will not turn off. I have to shut the p12r off via power supply. Now I have tried this with 3 different stands and the same thing happens. It is like they get the first command and forget the rest. Now if I take a stand or any other and hook it directly to the controller with no extension I can get the controller(LSP) to turn on and chase but not reach the end of the strand or the last 10 pixels. Now it does this with a few different sets of pixel strands. Now RGB is the right way to go but all the LOR cards off the ECG_d2 are working great....but need help here I have tried different rates for the 2811 IC in the string config page on the p12 from 3000 down to 2000. WHat am I missing guys

    Zane
     
  2. kane

    kane Dedicated Elf

    Joined:
    Dec 23, 2010
    Messages:
    1,021
    Likes Received:
    0
    Location:
    Trigg (Northern suburbs of Perth)
    Find Me On:
    Just on this part of it - how are you testing this from LSP - using an actual sequence, or just using the "test controller" functionality?

    The test controller functionality only outputs a certain number of channels (10x rgb I think?), so you'll want to make sure you test using an actual sequence (with output turned on, and make sure you optimise the sequence first)
     
  3. crispy

    crispy Apprentice Elf

    Joined:
    Jun 12, 2012
    Messages:
    72
    Likes Received:
    0
    Location:
    Fraser Lake
    xlights or da_e1.31 testers will do whole universes
     
  4. anon

    anon Apprentice Elf

    Joined:
    Dec 30, 2011
    Messages:
    91
    Likes Received:
    0
    Location:
    Adelaide

    I'm happily running a 6.5m extension to a 9.6m 2811 strip at 2400. However I'm still using 180X protocol (ain't broke, won't fix it)


    I would suggest:
    -Flick on dip switch 4 and reboot to initiate the test sequences. If this sequences fine this all but eliminates the controller.
    -If it's not reaching the end of the strip sounds like you haven't ticked set 30 pixels in the string config. Also double check the effects has the right number of pixels too and is made active.
    - Double check you have all channels mapped to the controller (not pixel count!!)
    - Only use one core of a pair for the data, don't use 2, this my cause some funkiness. I've run WS2811 on 6m of CAT 5, +ve one pair, -ve pair another and data on 1 core of a pair, with the other core unterminated.
    - Try another cable?
    - Use the 'test controller' option of LSP, there is some weirdness when playing sequences at the start, I had similar issues thinking trying to work out what was going on, and no surprise it was LSP not behaving.
     
  5. OP
    OP
    z_special

    z_special Full Time Elf

    Joined:
    Feb 2, 2012
    Messages:
    111
    Likes Received:
    0
    Location:
    Edmonton Alberta
    as far as the 2 pair goes red for V+ black for v- and white for data....I am going to try a extension cord tomm during the day time and see what happens 16 gauge 3 wire SOOW cable very flexable and lots of strands
     
  6. OP
    OP
    z_special

    z_special Full Time Elf

    Joined:
    Feb 2, 2012
    Messages:
    111
    Likes Received:
    0
    Location:
    Edmonton Alberta
    Kane I am using the test contoller hardware where you choose the first controller and you can turn on or off each channel like R OR G or B by itself or as a group of 3.....but in this capacity LSP goes up to channel 90 of configured for 30 pixels(90 channels).
     
  7. Bevo

    Bevo Let your Light Shine before men

    Joined:
    Dec 30, 2010
    Messages:
    315
    Likes Received:
    0
    Location:
    Caboolture QLD
    Find Me On:
    Can you try and use a short lead about 1.6m long?


    Just to test it, and tick the test enable on the P12R to get the P12R outputting its own test pattern then try using the LSP hardware tester.


    See if the shorter distance helps.
     
  8. Benschristmaslights

    Benschristmaslights Dedicated Elf Global Moderator Generous Elf

    Joined:
    May 2, 2010
    Messages:
    2,130
    Likes Received:
    8
    Location:
    Elderslie
    Find Me On:
    zane have you tried going down to 1500???
     
  9. OP
    OP
    z_special

    z_special Full Time Elf

    Joined:
    Feb 2, 2012
    Messages:
    111
    Likes Received:
    0
    Location:
    Edmonton Alberta
    i will try down to 1500 and try a new cable I made up at work tonight so we will see. I just don't understand why LSP will not turn on the last few pixels of the strand when connected directly to the p12 when using the hardware test. I will try a new universe for that as well....grrrrrrrrrrrrr
     
  10. OP
    OP
    z_special

    z_special Full Time Elf

    Joined:
    Feb 2, 2012
    Messages:
    111
    Likes Received:
    0
    Location:
    Edmonton Alberta
    No time to worry about it now as in today just digging out from 15 cm of snow in 3 hours....have to head to my parents place to shovel there now.
     

Share This Page