1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

Release 4.0.8

Discussion in 'xLights (Nutcracker)' started by smeighan, Mar 29, 2015.

  1. smeighan

    smeighan Dedicated Elf

    Joined:
    Jan 19, 2012
    Messages:
    1,066
    Likes Received:
    9
    Location:
    4217 Greenfinch Dr CO 80126
    RELEASE 4.0.8 for xLights


    It has been 8 days since we did the beta release of xLights 4.0.0
    There has been one release per day since then. Our thanks to Gil Jones and Dan Kulp who have created so much new content.




    XLIGHTS/NUTCRACKER RELEASE NOTES:
    ---------------------------------
    4.0.8 Mar 28, 2015
    Gil Jones has been busy on this Saturday, Mar 28th
    -- bug (gil) Error message when audio file missing #116
    -- bug (gil) Drawing and selection issues in EffectsGrid #115
    -- bug (gil) Move multiple elements at once using Render Position (move up/move down) in Sequence Elements Frame #114
    -- bug (gil) Purple effect highlight in grid is not moving with the mouse click to next effect. #113
    -- bug (sean) Title bar says 4.0.67 versus 4.0.7 #112
    -- bug (gil) 4.0.6 File, New sequence does not scrub screen from previous sequence #111
    -- bug (gil) 4.0.6 Hard Crash on opening subsequent sequence #110
    -- bug (gil) Can't cancel New Sequence #76
    -- bug (gil) Ability to close the current open sequence #37
    -- bug (gil) Dragging selection of effects similar to #59 #79
    -- enh (sean) Created "House Preview" icon to be used on tool bar. This will cycle display on/off


    To see latest releases: http://nutcracker123.com/nutcracker/releases/
    To find MAC releases: http://dankulp.com/xlights/?C=M;O=D
    To get more info on the issues listed: https://github.com/smeighan/xLights/issues
     
  2. thevikester

    thevikester Apprentice Elf

    Joined:
    Dec 15, 2012
    Messages:
    55
    Likes Received:
    0
    Location:
    Florida
    Find Me On:
    Looking good Sean and Team! I did notice with the last 2 releases, for me anyways, when I click on the zoom, the wave form disappears. I can click where it is supposed to be, it reappears. When I put in an effect in the grid, it disappears,...the only hinderence is when doing timing marks from the wave form, it disappears, reappears, etc...is anyone else experiencing this... I'm running Windows 7. I uninstalled completely, and reinstalled, and still does the same thing... :eek:
     
  3. Gilrock

    Gilrock Full Time Elf

    Joined:
    Jan 4, 2013
    Messages:
    389
    Likes Received:
    6
    Location:
    Tucson, AZ
    Find Me On:
    The waveform refresh issue appears to be fixed in 4.0.9. Although it messed up the waveform refresh 4.0.8 did add some great improvements to the responsiveness of the application. Watch this video to see how it improved between 4.0.7 and 4.0.8. And then 4.0.9 fixes the flashing you see in the video which also should fix it disappearing for some users. The funny thing is you can hear me think of the idea of to fix this while I'm making the video.
    https://www.youtube.com/watch?v=QiiUUSUGp0g
     

Share This Page