1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

DMX issue in LOR

Discussion in 'LOR General Discussion' started by Bokines, Nov 9, 2014.

  1. Bokines

    Bokines New Elf

    Joined:
    Jun 29, 2014
    Messages:
    28
    Likes Received:
    0
    Location:
    North Gosford, NSW
    I am at the final stage of putting my show together in LOR and have run into an issue. I have 11 LOR boxes running my 240v elements and 24 CCR's for my screen and Roof top tree. This year I have added 5 of Rays 27 Channel DMX boards to run some dumb pixels. 4 controllers run 4 fans each with 8 outputs, a total of 24 channels per fan. I then have the 5th DMX card running 9 mini trees of dumb pixels. A total of 6 LOR 485 dongles are used in for the output. One of those dongles is used to output to the DMX 27 channel boards.

    I have made the fans occupy the first DMX channels 1 to 96. The trees then occupy the next 27 channels 97 to 123. All 5 DMX boards are run under universe 1 as the total channel count does not exceed 512.

    When I run my show every thing except the trees run. When I look at the boards, the first 4 running the fans have the red light flashing however the board running the trees has the red light steady.

    Can anyo e suggest what the issue may be.
     
  2. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,548
    Likes Received:
    14
    Location:
    Eaglehawk
    Find Me On:
    The issue almost may be wiring as the boards themselves don't care what order etc they are in. I would try swapping leads around to see if that isolates things. The other possibility is that the RS485 receive chip may be damaged. I think that the chip is socketed on those boards so you may be able to swap from 1 board to another to see if that is the case. The chips are available pretty easily and there are a bunch of compatible chips.
     
  3. Ɠαяєтн

    Ɠαяєтн Mae gen i C.L.A.P ei heintus iawn

    Joined:
    Dec 27, 2010
    Messages:
    160
    Likes Received:
    0
    Location:
    Landsdale, Perth, Western Australia
    Can you draw a picture of your controller setup, this might be easier. LOR 1-96 for four controllers is not making sense, if using LOR in DMX mode, it uses blocks of 16 DMX channels. So the starting DMX channels for each LOR board should be 1, 17, 33 and 49, that is assuming that you have set there addresses to 01, 02, 03 and 04. See attached pdf.


    Ray's 27 Channel DMX boards, use a different wiring format to LOR, see wiki



    How is your LOR network preferences set up? LOR dongles do not use Universes, that is for DMX over ethernet or e1.31.





     
  4. Superman

    Superman I Have C.L.A.P and its very infectious Global Moderator

    Joined:
    May 29, 2010
    Messages:
    1,627
    Likes Received:
    15
    Location:
    Ipswich-QLD
    Find Me On:
    lights flashing on boards is a good or bad thing depending on the board type for LOR the light being steady or completely off means it is getting a DMX signal. DMX boards like the ray 27 ones are the opposite flashing light on the board means it seeing DMX.

    I would check your cables first.
     
  5. OP
    OP
    Bokines

    Bokines New Elf

    Joined:
    Jun 29, 2014
    Messages:
    28
    Likes Received:
    0
    Location:
    North Gosford, NSW
    I have attached a diagram of my setup. The DMX boards are all on one 485 dongle and in the DMX setup in LOR they this dongle is set to universe 1.
     

    Attached Files:

  6. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,548
    Likes Received:
    14
    Location:
    Eaglehawk
    Find Me On:
    A pdf that anyone could view rather than a M$ format file would be good so that the masses could have a gander. Words security settings don't let a document created on another computer be opened easily these days.
     
  7. starzen

    starzen New Elf

    Joined:
    Oct 13, 2012
    Messages:
    44
    Likes Received:
    0
    Location:
    Stuart, Florida
    Find Me On:
    so the trees are not working but everything else is

    that means that any of the following can be bad

    wiring from the fans to the trees
    the controller for the trees
    somehow not the complete universe is sent
    address setup on tree controller
    wiring from the tree controller to lights
    tree lights

    a simple test would be the following

    change the DMX address on your tree to be the same as your fan and see if the tree now works (should get the same data as the fan).

    if it lights up either the address on the controller was wrong or you are not getting the data with the address you had set for the tree

    if it doesn't light up something is wrong either with the wiring from the fans to the tree or the controller is bad or the wiring from the controller to the trees or the lights. In that case I would try to hook up the tree controller directly to the dongle without the fans.

    if it still doesn't work try to switch controllers to see if the problem goes away when using a controller from the fans
     
  8. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,548
    Likes Received:
    14
    Location:
    Eaglehawk
    Find Me On:
    Several of those can be taken out of the equation because the board blinks when it is getting dmx data. This pretty much means that it's not getting data or that the address selected isn't valid and I don't know what the board does if you set the address to 0.
     
  9. OP
    OP
    Bokines

    Bokines New Elf

    Joined:
    Jun 29, 2014
    Messages:
    28
    Likes Received:
    0
    Location:
    North Gosford, NSW
    PDF File of LOR layout
     

    Attached Files:

  10. AAH

    AAH I love blinky lights :) Community Project Designer

    Joined:
    Dec 27, 2010
    Messages:
    2,548
    Likes Received:
    14
    Location:
    Eaglehawk
    Find Me On:
    Great picture that explains how things are connected well.
    Red led on the board says that power is connected which is always the 1st step to check.
    Red led isn't flashing which means there is no dmx data. A bunch of things that can stop this.
    1) Check that a valid start address is set
    2) Swap out the dmx wires going from 27ch board 4 to 5 to rule out that.
    3) If an rj45 socket has been added to the board that it has been fitted correctly. If possible meter from 1 board to the next to make sure that there is continuity.
    4) If the above doesn't solve the problem then look at the rs485 receive chip.
     
  11. OP
    OP
    Bokines

    Bokines New Elf

    Joined:
    Jun 29, 2014
    Messages:
    28
    Likes Received:
    0
    Location:
    North Gosford, NSW
    11:30pm and finally everything is up and running. Thanks for the advise on the 485 chip. Appears 2 of the boards did have faulty chips. Luckily I had several spare boards. Will look on the net for some replacement chips tomorrow. Thanks again. This is my first year of DMX Dumb and Smart pixels. So much work but should be worth while. Now to incorporate my 32 string smart pixel mega tree into my display. I think it will run separately from xlights this year as I have run out of time for sequencing. will post videos soon.
     

Share This Page