1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

Help with BBB Setup

Discussion in 'Falcon (Pi) Player' started by i13, Aug 8, 2015.

  1. i13

    i13 Senior Elf

    Joined:
    Jul 5, 2013
    Messages:
    783
    Likes Received:
    10
    Hi all

    I want to ask if there's anyone within driving distance of Adelaide, South Australia who could help me install Falcon Player on a BeagleBone Black if I bring it over because I couldn't get it to work. I'm planning to use it with a PixelBone.

    I was going to wait until the next Falcon Player release which should be easier to install; the thing is that I want to see it work because I'll join the planned second F16v2 group buy if it doesn't work.

    Thanks in advance
     
  2. OP
    OP
    i13

    i13 Senior Elf

    Joined:
    Jul 5, 2013
    Messages:
    783
    Likes Received:
    10
    Ok the lack of replies doesn't look promising.

    Does anyone know when the next Falcon Player release is expected? I thought it was going to be soon but there's still no guarantee that I'll get it to install either.

    And of course please still reply if you can help me set it up. The bulk buy for the F16V2 closes on August 30th so I really want to have this working by then.
     
  3. AussiePhil

    AussiePhil Dedicated Elf Administrator

    Joined:
    Jun 20, 2009
    Messages:
    1,391
    Likes Received:
    1
    Location:
    Canberra, ACT, Australia
    Find Me On:
  4. OP
    OP
    i13

    i13 Senior Elf

    Joined:
    Jul 5, 2013
    Messages:
    783
    Likes Received:
    10
    Thanks AussiePhil but I'm still having a problem

    I'm following the instructions to the word but the lights don't start flashing when I hold the button while turning on the power. I even tried holding it for 5 minutes at one point.
    http://falconchristmas.com/forum/index.php/topic,2742.0.html

    I've tried installing to the SD card and to the EMMC but neither seem to work even though I had the right images. I've tried powering via the USB connection and the separate 5V input (not at the same time) so that's not the issue either.

    I've been on the ACL chat asking about this and so far no-one knows what's going wrong.
     
  5. Benschristmaslights

    Benschristmaslights Dedicated Elf Global Moderator Generous Elf

    Joined:
    May 2, 2010
    Messages:
    2,130
    Likes Received:
    8
    Location:
    Elderslie
    Find Me On:
    have you tried another sd card just incase your one is faulty??
     
  6. OP
    OP
    i13

    i13 Senior Elf

    Joined:
    Jul 5, 2013
    Messages:
    783
    Likes Received:
    10
    No I don't have another SD card to try but the one I have is an 8 GB class 10 one that I bought recently. I haven't used it for anything else. I get the message saying it formatted correctly but you're right that it's possible the BBB won't talk to it.

    That reminds me, I have tried two different USB drives for the SD installation and that didn't help. One of them is 16 GB and designed for USB 3 speeds. The other is an old 4 GB one that was lying around.

    Thanks for the suggestion; I'll try it if a spare SD card turns up.
     
  7. Gilrock

    Gilrock Full Time Elf

    Joined:
    Jan 4, 2013
    Messages:
    390
    Likes Received:
    6
    Location:
    Tucson, AZ
    Find Me On:
    There's always a chance the BBB has a problem. We had one person at the Texas Expo try to get his BBB up and running and Captain told him the board was dead of out the box.
     
  8. OP
    OP
    i13

    i13 Senior Elf

    Joined:
    Jul 5, 2013
    Messages:
    783
    Likes Received:
    10
    I want to say a big thanks to elnino for getting it working.

    There were two main problems. The worst problem was that the image files hadn't unzipped correctly. I ended up with a bad file named 1.img using 7-Zip and continued the setup with this file. Win32DiskImager didn't detect the problem when writing to the SD card so it said the process was successful. The second problem that occurred later was that the BBB kept trying to boot off of the SD card even though Falcon Player was installed on the eMMC. This was not the same SD card used for the successful installation. Using a USB drive avoided the issue but please post here if you know why this was happening.

    I'll be trying to access it just through a network switch sooner or later so I may post back here if I have any issues because I don't know much about networking.

    Anyway, mission accomplished; I have FPP working before the F16v2 group buy closes which proves I won't need a F16v2. :)
     
  9. SmartAlecLights

    SmartAlecLights Im a SmartAlec what can i say! Community Project Designer

    Joined:
    May 4, 2010
    Messages:
    1,205
    Likes Received:
    12
    Location:
    S.A.
    Find Me On:
    Glad elnino could help you get it going..
    (you know he also has a pixelbone as well if you need extra help along the way)
     

Share This Page