Newbie need help WS2811 with T-1000S

Discussion in 'RGB Lights - Intelligent Pixels and 3-Channel RGB' started by Grumpy, Jan 14, 2015.

  1. Grumpy

    Grumpy New Elf

    Joined:
    Dec 28, 2014
    Messages:
    9
    Likes Received:
    0
    Location:
    Folsom, CA
    Folks, I bought a strand of 12mm WS2811 and a T-1000S for testing, Not clear to how I'll used the T-1000S, but I got it quick, and cheap. I've never used or seen WS2811 in use so I bought these to see what I could learn.

    Used LEDEdit 2012 to setup a small sequence. - copied to a FAT formatted SD and inserted into the T-1000S.
    Wired 5V power supply + to 5V and - to Ground.
    Wired Non-chip side, first pixel VCC to +5V Power and Grd to -5V power
    Wired Non-chip side DI to DAT and Grd to Grd.

    Tested power to ensure 5V and there is 30W available for Controller and only 25 Pixels.

    When powered, the T-1000S power indicator comes on, and no error light......but no pixel sights

    What is happening??????

    How can I test controller, and/or Pixels.


    Controller User Manual Link: http://www.kutop.com/program/T_1000S_SD_card_program_manual.pdf
     
  2. mborg10

    mborg10 Michael Borg

    Joined:
    Dec 28, 2011
    Messages:
    1,446
    Likes Received:
    0
    Location:
    claremont meadows
    What did you call the file names
     
  3. OP
    OP
    Grumpy

    Grumpy New Elf

    Joined:
    Dec 28, 2014
    Messages:
    9
    Likes Received:
    0
    Location:
    Folsom, CA
    Export named it: 00_1.led, so I used it. Manual verifies correct.
     
  4. mborg10

    mborg10 Michael Borg

    Joined:
    Dec 28, 2011
    Messages:
    1,446
    Likes Received:
    0
    Location:
    claremont meadows
    Does the wire coming directly out of the pixel connect to the ground on the controller AND the ground on the power supply
     
  5. OP
    OP
    Grumpy

    Grumpy New Elf

    Joined:
    Dec 28, 2014
    Messages:
    9
    Likes Received:
    0
    Location:
    Folsom, CA
    I used 5V & Grd From Controller to Pixel V+ & V-(Grd), and DAT & Grd to Pixel DI & Grd. Both Ground terminate at same Factory solider joint on pixel board.

    Pixel to Controller then to 5V Power Supply
     
  6. mborg10

    mborg10 Michael Borg

    Joined:
    Dec 28, 2011
    Messages:
    1,446
    Likes Received:
    0
    Location:
    claremont meadows
    Run + and - to power controller.
    To power pixel run + direct from power supply and - from power supply AND grnd output on controller. Connect data to controller output.
     
  7. OP
    OP
    Grumpy

    Grumpy New Elf

    Joined:
    Dec 28, 2014
    Messages:
    9
    Likes Received:
    0
    Location:
    Folsom, CA
    I think I found the issue.....software problem. LEDEdit controller/pixel configurator issue. First step in the software is to select your controller and pixel. Mine was T-1000S-WS2811, however this configuration must of had something crossed linked when zipping the download file. I removed all the standard, selectable controller/pixel listed, and re-selected T-1000S-WS2811 from the master list. Then followed the previous steps to make a file. Tested and I now have lights.

    Hope this will help others with a T-1000S controller issue.
    T-1000S is not my choice of a controller. I will not buy another.
     

Share This Page