rPi interference on FM transmitter

TheRichardsons

New elf
Joined
Nov 22, 2017
Messages
10
Hi Everyone!
I'm pulling my hair out here.
I've got an rPi running FPP to a f16V3, and a ST-7C FM transmitter.

When I run an audio cable from the USB Audio or directly from the pi, I get terrible interference (hum, buzz, feedback.. all sorts)

When I run audio from an iPad or phone there is almost zero interference.

Any tips on how to fix this?

Thanks team!
 

AAH

I love blinky lights :)
Community project designer
Joined
Dec 27, 2010
Messages
3,388
Location
Eaglehawk
1 issue with the Pi's is that the 3.5mm audio output is actually a 4 pin plug with video on it as well as the standard audio. If you haven't used a 4 pin to 3 pin adaptor of some sort then turning off the video on FPP may give you a reduction in what could quite possibly be video that you are hearing.
 

B4IGO

New elf
Joined
Dec 12, 2016
Messages
24
Location
Sydney
1 issue with the Pi's is that the 3.5mm audio output is actually a 4 pin plug with video on it as well as the standard audio.
Oooooooh! That might explain why my Pi shuts down when i turn on my transmitter?
 

David_AVD

Bite my shiny metal ass!
Community project designer
Generous elf
Joined
Jun 12, 2010
Messages
4,081
Location
Victoria Point (Brisbane)
Could also be a power (not enough current - voltage dropping) issue if the pi is sharing the same power supply as the transmitter?
 

B4IGO

New elf
Joined
Dec 12, 2016
Messages
24
Location
Sydney
Another good thought David. They are on different plug packs though. I have a sound blaster coming so will see what that does... and when i get some time will dig into it further.
 

TheRichardsons

New elf
Joined
Nov 22, 2017
Messages
10
I'll give it a shot. I've noticed left is louder than right with this transmitter as well. (even when running off iPad).
 
Top