TigerDMX120v1 Firmware Release 1.03.00 for PIC 2553

AussiePhil

Dedicated elf
Administrator
Joined
Jun 20, 2009
Messages
1,386
Location
Canberra, ACT, Australia
All

Release 1.03.00 for the PIC2553 if used to build a T120

this is just a compile of the 2550 code for the 2553 pic, unable to directly test hardware but a PIC can be programmed.

EEPROM is set by default to start Channel 1

Please report issues in the thread and via PM

Phil
 

Attachments

Blickensderfer

Ohio, USA
Joined
Jun 6, 2010
Messages
390
Location
Gnadenhutten, OH
Phil,

I just tested the firmware on the 2553 and it's a no go.. I get the following leds on. 5 volt good, and the Output On and PIC active leds are on but had a random flicker.


Correction!!!!!!!!!

I did get it to work.. I didn't know that the jumpers had to be on the TX and the RX pins.. Once I did that it came alive.. :D I had to watch the 3rd part of video to see the jumpers.


Now the only thing is the additional starting channel settings.

Thanks,
Dan
 

Blickensderfer

Ohio, USA
Joined
Jun 6, 2010
Messages
390
Location
Gnadenhutten, OH
Phil,

I don't know if it has to do with the firmware or not but when fading the leds either by manual test channel or within sequence, a quick fade to off. The leds flicker. It's not a real bad flicker but noticable. I have tried it on a couple different Tiger boards and effects are the same.

Thanks,
Dan
 

fasteddy

I have C.L.A.P
Global moderator
Joined
Apr 26, 2010
Messages
6,645
Location
Albion Park NSW
Blickensderfer said:
Phil,

I don't know if it has to do with the firmware or not but when fading the leds either by manual test channel or within sequence, a quick fade to off. The leds flicker. It's not a real bad flicker but noticable. I have tried it on a couple different Tiger boards and effects are the same.

Thanks,
Dan
Are you using LSP and the ECG.
 

Blickensderfer

Ohio, USA
Joined
Jun 6, 2010
Messages
390
Location
Gnadenhutten, OH
No.. I'm using Vixen and a Enttec Open to test with. I do have an Enttec Pro and ECG. I can try testing one of them but I also have a Lynx Express controller attached too. The flicker doesn't happen on the led status. But this isn't compairing apples to apples. different technologies.
 
Top