1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

Vast FMT-212R FM Transmitter Noise Issue

Discussion in 'Computers, Cabling & Other Miscellaneous Hardware' started by danv, Dec 2, 2018.

  1. danv

    danv Full Time Elf

    Joined:
    Dec 5, 2016
    Messages:
    188
    Likes Received:
    33
    Location:
    Rockhampton
    OK so I grabbed a new VAST FMT-212R this year and I have some intermittent noise issues.
    I set the frequency with a PC via the USB config software, that seems to work OK.
    However, when the show is running I get intermittent parts at various sections throughout my display where the FM transmission has really noisy audio and the only fix I have found so far is to open up the my FPP web interface and touch the volume slider (either up or down, direction doesnt matter) then the audio fixes itself until the next intermittent time it decides to go spastic.
    Anyone experienced this before or have any suggestions? I have tried playing direct to it (ie. selecting it as the output in FPP settings for audio), or using my usb soundcard that I used last year and running a 3.5mm aux lead from it to the transmitter, both yielding the same outcome.
     
  2. ChristmasInKaralee

    ChristmasInKaralee Senior Elf

    Joined:
    Feb 15, 2014
    Messages:
    543
    Likes Received:
    131
    Location:
    Karalee
    This is a known issue with the Vast and has been around for years. I had one and when I moved over to FPP it had this noise issue. I have since gotten rid of it and bought another transmitter. Not sure if the Bast works on FPP 2.x

    Sorry I don’t have the answer your after apart from adjusting the audio, but you can’t sit a the PC all night every night, which is what I had to do for a week until I got hold of another transmitter.
     
  3. OP
    OP
    danv

    danv Full Time Elf

    Joined:
    Dec 5, 2016
    Messages:
    188
    Likes Received:
    33
    Location:
    Rockhampton
    Damn. Was hoping there was a fix. Did anyone try contacting the manufacturer or is it believed to be an issue with how the FPP side talks to it?
     
  4. dkulp

    dkulp Apprentice Elf

    Joined:
    Jan 2, 2013
    Messages:
    53
    Likes Received:
    4
    Location:
    Framingham, MA
    it's only on the Pi (BBB -> VastFM is fine) and occurs with all the various Linux audio players, so nothing specific about FPP. It's some sort of linux usb kernel driver issue or something, but certainly not something any of us have any knowledge to be able to dig into. I use a BBB for my master partially due to the VastFM working fine with it.
     
  5. OP
    OP
    danv

    danv Full Time Elf

    Joined:
    Dec 5, 2016
    Messages:
    188
    Likes Received:
    33
    Location:
    Rockhampton
    OK dkulp thanks for that. I did actually find on git that issue related to this, it is fairly dated. Very interesting. I thought there was a way to simply make the vast use the aux in port only and only get power from the usb from the pi? ie. I keep my external usb soundcard and run a 3.5mm aux lead between it and the vast. Should rule out any linux/kernel issues if it then becomes a "dumb" audio device and not a usb digital sound device if that makes sense? Will investigate more tomorrow, there may be a setting in the weird vast software for this.
     
  6. lithgowlights

    lithgowlights Senior Elf Generous Elf

    Joined:
    May 6, 2010
    Messages:
    844
    Likes Received:
    93
    Location:
    Lithgow, NSW
    Find Me On:
    I dont use the Pi output as that is terrible, so I bought a little USB Soundblaster dongle this year and it's great. Way better than the Pi and even the VAST itself via the Pi's USB
     
  7. dkulp

    dkulp Apprentice Elf

    Joined:
    Jan 2, 2013
    Messages:
    53
    Likes Received:
    4
    Location:
    Framingham, MA
    You cannot plug it into the USB on the pi. If the Vast detects a USB connection, it only will use data from that. If you power the vast from a usb wall wart thing so no data, then the 3.5mm audio jack should work.
     
  8. dennismc

    dennismc New Elf

    Joined:
    Jan 23, 2014
    Messages:
    10
    Likes Received:
    0
  9. David_AVD

    David_AVD Bite my shiny metal ass! Community Project Designer Generous Elf

    Joined:
    Jun 12, 2010
    Messages:
    3,865
    Likes Received:
    218
    Location:
    Victoria Point (Brisbane)
    Find Me On:
    Another option would be to carefully "doctor" a short USB extension cable and cut the 2 data wires (green and white) while leaving the power (black and red) intact. That would get you the power feed with no data connection.
     
  10. OP
    OP
    danv

    danv Full Time Elf

    Joined:
    Dec 5, 2016
    Messages:
    188
    Likes Received:
    33
    Location:
    Rockhampton
    Nice. I wasnt aware of this. I will try it asap.
     
  11. OP
    OP
    danv

    danv Full Time Elf

    Joined:
    Dec 5, 2016
    Messages:
    188
    Likes Received:
    33
    Location:
    Rockhampton
    Good idea David. Thank you.
     
  12. OP
    OP
    danv

    danv Full Time Elf

    Joined:
    Dec 5, 2016
    Messages:
    188
    Likes Received:
    33
    Location:
    Rockhampton
  13. OP
    OP
    danv

    danv Full Time Elf

    Joined:
    Dec 5, 2016
    Messages:
    188
    Likes Received:
    33
    Location:
    Rockhampton
    Yes I agree. I use a usb soundcard already and have a 3.5mm aux lead from it to the VAST, I think my issue is that I am powering the VAST from a Pi USB port with the data lines still intact. Going to try as people have suggested above today and see if making the VAST a "standalone" device with a aux in only works. Shall let you know how I go. The volume up/down script will be worth implementing if this doesnt correct the problem though.
     
  14. OP
    OP
    danv

    danv Full Time Elf

    Joined:
    Dec 5, 2016
    Messages:
    188
    Likes Received:
    33
    Location:
    Rockhampton

Share This Page