1. New to Christmas lighting? Get started with the AusChristmasLighting 101 Manual:
    auschristmaslighting.com/wiki/AusChristmasLighting-101

FPP Won't Run Scheduler/Play Playlist Until I Plug Ethernet In

Discussion in 'Computers, Cabling & Other Miscellaneous Hardware' started by TastyHamSandwich, Jul 24, 2018.

  1. TastyHamSandwich

    TastyHamSandwich New Elf

    Joined:
    Apr 18, 2018
    Messages:
    3
    Likes Received:
    0
    Greetings, everyone!

    So I've got something of a unique issue in front of me, suddenly. I haven't seen this problem in the past, but I've so far been unable to roll back to a version of FPP that doesn't do this to me. I warn you now of the wall of text that is coming up, so skip to the bottom for the TL; DR. When I get nervous, I get chatty, and the anxiety is surely getting to me right now, haha!

    So! The issue:

    I've got a couple of RPi's set up to drive some simple singing faces, using an LOR controller to power two 8-channel fixtures. I want it to play the show all the time, 24/7, without anything fancy. These RPi's don't have a true RTC, but they do have a UPS hat that allows them to maintain the system time, and the schedule is configured to play the song list all day, every day (12:00am-11:59pm, 7 days/week). Configuration-wise, FPP is set up to solely output ch1-ch64 via the LOR dongle it has attached by USB. I have the E1.31 output disabled, as I don't need it running on these specific RPi's, and the issue was present with it Enabled, as well as Disabled, so there's no reason I see to keep it enabled. This has all been configured correctly & tested - playback works just fine, but getting to this point is the issue.

    The problem is, the FPP doesn't want to auto-run the show until it detects the presence of an ethernet connection. I've posted about this on Falcon Christmas, and dan kulp had me try:

    'sudo systemctl disable connman-wait-online'

    in an attempt to make it stop waiting for ConnMan to receive an IP address that isn't coming. To that end, the command worked perfectly. When I boot the RPi, it skips right past waiting for an IP address and gets to the CLI in record time, given it has no IP address. Unfortunately, it still doesn't begin playback automatically like it is supposed to; I still have to plug in an ethernet cable before it will fire off. And to be clear, once I plug that cable in, the show does indeed fire off, almost instantly.

    I'm trying to figure out a work-around for these units, and I'm curious if anyone has any thoughts on what I might try to either correct the problem, or sidestep it. Right now, I have the thought of custom-making an ethernet cable that shorts/jumps certain pairs, in an effort to trick it into thinking it is plugged in to something. A similar device is used on the T1 modem at my dad's house, and for similar purpose too (something about being there to trick the modem's firmware into thinking some other device is attached that isn't). I'd have no idea how to construct the proper kind of cable for what I need, or even if it is possible. But if it is, does anyone have any suggestions on how to build it properly, or any other ideas or recommendations for a fix or workaround for this issue entirely?

    Insofar as the nature of the problem, I am currently thinking that FPPD is, in osome way, the culprit. Can I potentially use a script to auto-fire the show I want it to play when it boots up? Currently, it's just managed by the scheduler, and given the standard wide range of years (2014-2099). If there's a pre-built script in the repository or something I can write up real fast, something that can make it fire off a playlist (and repeat it ad infinitum) as soon as it boots up, I'm more than happy to go that route... I'm just not familiar with scripting in the FPP environment... what language it uses/where to find function/syntax documentation/tutorials... I'm just bad at the scripting side in general, currently.



    I've gone on and on in circles long enough, now, so TL; DR:


    My RPi3/FPP won't play my show until I plug in an ethernet cable. All the data for the fixtures is output via an LOR
    dongle, so E1.31/Art-Net is disabled, and the show's single playlist of 10 songs is auto-run by the Scheduler. When I boot the RPi, it sits there looking pretty, until the moment I plug an ethernet cable into it, where it then fires off almost instantly, the playlist it is supposed to play. This is what I need resolved, or work-around'd.... I need to be able to plug this thing in and walk away, knowing it will boot and play the show without any further input from me.


    Thanks for sticking with me and reading this whole thing, or even just making it here through the TL; DR. I really need to find a solution to this bizarre problem, as soon as possible, as these fixtures are supposed to ship out soon, and I hope to avoid a big delay over this weird issue. I really appreciate your time in reading all of this mess, and for your help in getting this issue solved. Thank you.
     
  2. Barnabybear

    Barnabybear New Elf

    Joined:
    Mar 30, 2012
    Messages:
    31
    Likes Received:
    2
    Location:
    UK
    Hi, I have just done the same thing as I've lent out my mega tree for an event next weekend. I to used a schedule from 00:00:00 to 23:59:00 and dates 02-01-2017 to 31-12-2099 this auto runs on power up (or about 30 seconds after power up with boot time). I used a fixed IP as there is no router, the settings are under 'Network'.

    On a side note: I'm using a button to shut down FPP after which it can be manualy powered off. This is done with the 'Shutdown script' and 'event' and a 'GPIO input'.
     
    Last edited: Jul 24, 2018
  3. AAH

    AAH I love blinky lights :) Community Project Designer Generous Elf

    Joined:
    Dec 27, 2010
    Messages:
    2,871
    Likes Received:
    166
    Location:
    Eaglehawk
    Find Me On:
    Having a static IP is what I would try. Having an IP assigned regardless of whether it is used or not means that it doesn't attempt via DHCP. If you have that already and it still causes issues then it's above my pay grade.
     

Share This Page